[darcs-users] dataenc on GHC 6.8?

Eric Kow kowey at darcs.net
Wed Oct 7 12:40:13 UTC 2009


Dear Magnus,

The Darcs Team is about to merge in a rather large piece of work, but
one potential sticking point (we just realised) is that dataenc does not
appear to install on GHC 6.8.

On Wed, Oct 07, 2009 at 13:33:29 +0100, Eric Kow wrote:
> I'm almost ready to push this (thanks to Ganesh's go-ahead from his
> previous message), but there is one issue from the GHC-6.8 staging
> I dusted off for this purpose
> 
> $ cabal install -fdeps-only
> Resolving dependencies...
> cabal: cannot configure dataenc-0.13.0.0. It requires base >=4.0.0 && <4.2
> For the dependency on base >=4.0.0 && <4.2 there are these packages:
> base-4.0.0.0 and base-4.1.0.0. However none of them are available.
> base-4.0.0.0 was excluded because base-3.0.2.0 was selected instead
> base-4.0.0.0 was excluded because darcs-2.3.1 requires base ==3.* && >=3 &&
> ==3.*
> base-4.0.0.0 was excluded because of the top level dependency base -any
> base-4.1.0.0 was excluded because base-3.0.2.0 was selected instead
> base-4.1.0.0 was excluded because darcs-2.3.1 requires base ==3.* && >=3 &&
> ==3.*
> base-4.1.0.0 was excluded because of the top level dependency base -any

By any chance, is this easy to fix, eg by loosening the dependencies?

Thanks!

Eric

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20091007/37eb916c/attachment.pgp>


More information about the darcs-users mailing list