[darcs-users] dataenc on GHC 6.8?

Eric Kow kowey at darcs.net
Wed Oct 7 14:43:33 UTC 2009


On Wed, Oct 07, 2009 at 14:40:30 +0100, Magnus Therning wrote:
> > The Darcs Team is about to merge in a rather large piece of work, but
> > one potential sticking point (we just realised) is that dataenc does not
> > appear to install on GHC 6.8.
> 
> My gut feeling is that it should be fine.  I don't think I'm advanced
> enough in my Haskell programming to use any GHC-6.10-only features, or
> even recent stuff in base...

Phew.  Looks like Darcs builds and passes tests just fine if we loosen
those dependencies.

> The main reason for putting a rather strict limit on base is that I
> don't have any systems around with older versions of GHC.  I'd very
> much appreciate any reports on it working (or not) with GHC 6.8, then
> I can adjust the requirements and upload a new version ASAP.

Patch sent.  Thanks very much!

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20091007/d1cc5496/attachment.pgp>


More information about the darcs-users mailing list