[darcs-users] Building under OS X 10.6

Florian Gilcher darcs-lists at andersground.net
Mon Oct 19 14:55:05 UTC 2009


On Oct 19, 2009, at 8:51 AM, Eric Kow wrote:

> On Sun, Oct 18, 2009 at 11:49:50 -0230, Florian Gilcher wrote:
>> Just before someone cares about this too much:
>>
>> Darcs eats meaningful errors, like this one:
>>
>> darcs failed:  Codec.Compression.Zlib: incompatible zlib version
>>
>> Removing `catchall` in Cache.hs did the trick.
>
> I don't know if this helps at all, but darcs works fine for me under
> Snow Leopard.  Then again, I don't have one of these 64 bit  
> machines...

I finally got it working after playing around with some ld-flags,  
forcing
cabal to build zlib using the 32 bit version. It's just a bit  
frustrating
that the error was not reported as it was, but transformed into a much
more generic message that had me checking all kinds of permission  
problems
before.

And yes: its one of those fancy 64 bit machines :). Maybe I will loose a
few words about it on the wiki.

Thank you,
Florian Gilcher


More information about the darcs-users mailing list