[darcs-users] Installing darcs 2.3.1 on OS X is a royal pain

Scott Ribe scott_ribe at killerbytes.com
Sat Oct 24 17:47:44 UTC 2009


Thought you should be aware that for a new OS X (10.5.8 Intel) user, getting
darcs going could be difficult:

- Installed darcs 2.0 some time ago, no problems, very easy.

- Decided today to upgrade to 2.3.1.

- Downloaded the pre-built binary darcs-2.3.1-i386-darwin. It doesn't run,
crashes with a dyld error: unknown required load command 0x80000022. Net
searches turn up info that 22 was a load command added in 10.5.6, people
running 10.5.5 had this error with command-line utilities, updated to
10.5.6, and the error went away. Unfortunately I am running 10.5.8.

- Went ahead and ran otool on darcs, verified that it only links to dylibs
that are standard on OS X, and that they're all where expected on my system.

- Went down a dead-end by misreading the build-it-yourself instructions at
<http://www.darcs.net/manual/node8.html>. Looked at Setup, figured out that
it's not a shell script, but rather Haskell.

- Installed the pre-packaged GHC-10.4.

- Tried "ghci Setup.lhs configure" and so on, ran into issues with missing
packages.

- Tried cabal-install, cabal update, cabal install darcs. Got a working
darcs now.

-- 
Scott Ribe
scott_ribe at killerbytes.com
http://www.killerbytes.com/
(303) 722-0567 voice




More information about the darcs-users mailing list