[darcs-users] Installing darcs 2.3.1 on OS X is a royal pain

Scott Bell sctb at me.com
Sat Oct 24 18:57:48 UTC 2009


On 2009-10-24, at 12:13 PM, Eric Kow wrote:

> On Sat, Oct 24, 2009 at 11:47:44 -0600, Scott Ribe wrote:
>
>> - Downloaded the pre-built binary darcs-2.3.1-i386-darwin. It  
>> doesn't run,
>> crashes with a dyld error: unknown required load command  
>> 0x80000022. Net
>> searches turn up info that 22 was a load command added in 10.5.6,  
>> people
>> running 10.5.5 had this error with command-line utilities, updated to
>> 10.5.6, and the error went away. Unfortunately I am running 10.5.8.
>>
>> - Went ahead and ran otool on darcs, verified that it only links to  
>> dylibs
>> that are standard on OS X, and that they're all where expected on  
>> my system.
>
> This should be of interest to Scott and Fivesquare

I built 2.3.1 on 10.6, and unfortunately I do not have any machines with
10.5.x to test. I can try to build a GHC against the 10.5 SDK, if  
someone
would be willing to test it for me.

Regards,

- Scott



More information about the darcs-users mailing list