[darcs-users] darcs patch: modify issue1300 test to fail for the ri... (and 2 more)
kowey at darcs.net
Thu Sep 17 11:53:44 UTC 2009
On Thu, Sep 17, 2009 at 10:02:32 +0100, Kamil Dworakowski wrote:
> >> I have changed the definition of get_log not to delete the logfile, but to
> >> return it for deferred deletion. I capitalized on the fact that get_log
> >> was already returning (Just temp_logfile) for deferred deletion.
> >> get_log is an exported name, used in AmendRecord, Tag and Rollback. Some
> >> of them ignore the logfile to delete, though none of them accept
> >> --delete-logfile flag, and thus they don't need to change, nor are they
> >> affected in any way.
> >> Unintended side effect of the change: with --delete-logfile flag present, a
> >> massage '"Logfile left in " ++ filepath' gets printed in case of the test
> >> failure on record. This may actually be desirable so I did not bother to
> >> change it.
Actually, re-reading this log and trying to rewrite it to make it more
concise, I now think it's just about perfect.
> Is this only about some fuzzy line between what information should go
> into the patch log and what should go into the post description? Obviously
> greeting and such belong only to the post. My justification of the amendment
> also belongs to the post not to the log. Though in retrospect I could have
> put the justification for replacing removeFileMayNotExist with unchecked
> deferring of deletion (later it is removed using removeFile) inside the log.
Sorry, only fuzziness. I was going to say that it's probably best to
remove the coder from the log (I did foo; etc) and just focus on the
code (foo has this property), but then when I tried to write it that
way, it seemed horribly stilted so I preferred your version. Go
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 197 bytes
Desc: Digital signature
More information about the darcs-users