[darcs-users] darcs patch: relicense Darcs.Commands.GZCRCs as BSD3

Matthias Kilian kili at outback.escape.de
Sun Sep 20 13:04:07 UTC 2009


On Sun, Sep 20, 2009 at 09:41:44PM +0900, Stephen J. Turnbull wrote:
> Of course, the fact that
> those uses are "GPL compatible" means that Darcs can relicense and
> redistribute them under the GPL.

You can't relicense BSD licensed code without the permission of the
author. You can, however include it into GPL licensed code and
distribute the whole whint under the GPL. But the BSD licensed
pieces will be still -- BSD licensed. Compatibility with the GPL
just means that it doesn't add further restrictions to the GPLed
code.

Ciao,
	Kili


More information about the darcs-users mailing list