[darcs-users] Building darcs on Windows does not require MSYS

Salvatore Insalaco kirby81 at gmail.com
Mon Sep 21 15:34:23 UTC 2009


Dear darcs team,
thanks to the past efforts of cabalization, now compiling darcs on
windows requires just a recent version of GHC + cabal (haskell
platform is ok).

We do not need MSYS, except for running the test suite.

We should better avoid to mention it in release announcements, as MSYS
requirement will probably discourage some people.

We should also recommend to download a binary, when available, as a
curl-linked-with-pipeline darcs will be much faster than a "plain"
cabal one.

Salvatore


More information about the darcs-users mailing list