[darcs-users] dropping GHC 6.8

Ganesh Sittampalam ganesh at earth.li
Sun Apr 25 01:22:51 UTC 2010


We've just encountered a GHC 6.8 specific problem: 

In view of this, and given there is a general desire to drop it anyway, I 
think we should explicitly drop it from the 2.4 series. It's better to 
have the build fail than to potentially have runtime errors that are 
confusing and very offputting.

I'm not sure if there's a direct way to disable building with GHC 6.6 in 
the cabal file, but if not we could make one of the source files have a 
compile error if the GHC version is too low.

In line with the policy Eric outlined during the last discussion 
I've started putting together instructions on building darcs on debian 
lenny via installing a recent GHC on the wiki: 
http://wiki.darcs.net/Debian - I'd appreciate comments from the people who 
care about being able to do this on how useful the instructions are.



More information about the darcs-users mailing list