[darcs-users] dropping GHC 6.8

Yitzchak Gale gale at sefer.org
Sun Apr 25 07:52:32 UTC 2010


On Sun, Apr 25, 2010 at 4:22 AM, Ganesh Sittampalam wrote:
> We've just encountered a GHC 6.8 specific problem:
> http://bugs.darcs.net/issue1830

This problem may be specific to 6.8.2 and below only,
since it is related to GHC bug #2093. That bug was
fixed in 6.8.3.

It would be a *lot* easier to backport 6.8.3 to lenny
than to backport 6.10 and above.

> In view of this, and given there is a general desire to drop it anyway, I
> think we should explicitly drop it from the 2.4 series.

To put things in perspective: issue 1830 was reported
by people having trouble on the community.haskell.org
server, where many of the most important haskell projects
are hosted. That server is currently running Debian etch,
where the standard GHC is 6.6.

We are now in the process of upgrading that server to
lenny. There is still a possibility that we'll be able to run
squeeze, but my personal opinion is that it's unlikely.
In any case, the standard for hosted servers across the
Internet is lenny (or the equivalent in other distros).

I hope that even if we are on lenny we'll be able to
backport more recent versions of GHC and darcs to
run on the server. But that will take work. So
it will mean a further delay in being able to get
to darcs 2.4.

Overall, I would say that dropping support for GHC 6.8
would mean in practice that a significant proportion of
darcs users would be sticking with 2.3 and below for a
long time to come.

That's not necessarily so bad. It would just mean that
in order to provide good ongoing support for the
majority of the darcs user base, darcs developers
would need to support not only older versions of GHC,
but also older versions of darcs.

If 6.8.3 solves the mmap problem, would it be difficult for
the 2.4 series to support GHC 6.8.3?

Thanks,
Yitz


More information about the darcs-users mailing list