[darcs-users] Equality dependencies among support packages [was: Something is seriously wrong with Darcs on Windows]

Stephen J. Turnbull stephen at xemacs.org
Tue Apr 27 01:41:15 UTC 2010


Ganesh Sittampalam writes:

 > It's not actually that the interfaces are changing, but that we are trying 
 > to reduce confusion about whether a particular version of darcs has a 
 > certain bug or not. Previously we had lower-bound dependencies, and then 
 > darcs 2.4.1 might or might not have had a certain bug depending on which 
 > version of hashed-storage got linked in - and we don't even have a good 
 > way of displaying what version that was at runtime.

OK.  It's really a MacPorts problem in the end, but I've given up on
them -- Darcs devs are a bit more responsive.  I guess if it really
pisses me off I can rip out the port and build Darcs from upstream
source, and "port upgrade outdated" will work regardless of Darcs. :-)



More information about the darcs-users mailing list