[darcs-users] [patch138] Fix our version mechanism to make non-clean rebuilds p...

Reinier Lamers bugs at darcs.net
Sun Jan 17 20:57:00 UTC 2010


Reinier Lamers <tux_rocker at reinier.de> added the comment:

Op dinsdag 12 januari 2010 21:34 schreef Petr Ročkai:
> 1 patch for repository darcs-unstable at darcs.net:darcs:
> 
> Tue Jan 12 21:33:26 CET 2010  Petr Rockai <me at mornfall.net>
>   * Fix our version mechanism to make non-clean rebuilds pick up right 
version.

> +        sanity _ = error "eh"

I don't like this kind of non-descriptive error messages. What I'd really like 
to see in such a case is "No library found in package. If this happened to you 
during a 'cabal install', please report it as a bug to bugs at darcs.net".

I can imagine this will go wrong when a developer hacks the cabal file not to 
build the library to save time. Maybe it's just better to handle the case that 
there's no library.

For now, I am applying this patch to get 2.4 beta 2 out the door.

----------
nosy: +tux_rocker

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch138>
__________________________________


More information about the darcs-users mailing list