[darcs-users] [patch141] Include the exact package versions darcs was compiled

Petr Rockai me at mornfall.net
Tue Jan 19 00:22:02 UTC 2010

Ganesh Sittampalam <bugs at darcs.net> writes:
> This breaks the build for me with GHC 6.12.1, cabal-install 0.8.0, Cabal
> Haven't investigated further yet:
> Setup.lhs:225:43: Not in scope: `packageDeps'
> cabal: Error: some packages failed to install:
> darcs-2.3.1 failed during the configure step. The exception was:
> ExitFailure 1

It seems that cabal-install picks the system-wide Cabal for compiling
Setup, so even though I have 1.8 installed, I am using 1.6. That's why
this didn't get caught in my testing. Anyway, I have checked, and
packageDeps is now gone and replaced with componentPackageDeps, which is
however not available in 1.6.

My proposed course of action would be this:
- roll this back for 2.4 (probably on the release branch)
- on HEAD, bump required cabal version to 1.8
- fix HEAD to compile with 1.8 (breaking 1.6 here)
- fix HEAD to only compile libdarcs once (using the new 1.8 feature)

I can cabal-install Cabal 1.8 on GHC 6.8, although it will probably take
some persuasion to make cabal-install use it for Setup, actually. Maybe
it is smart enough to figure this out from the required cabal version in
the .cabal file. I'll look into this later...


More information about the darcs-users mailing list