[darcs-users] [patch147] Require Cabal 1.8, fix the build-deps du... (and 1 more)

Petr Ročkai bugs at darcs.net
Tue Jan 19 19:02:15 UTC 2010


New submission from Petr Ročkai <me at mornfall.net>:

There come patches that make darcs use Cabal 1.8.  The latter patch fixes the
excessive recompilation we have been hating since forever.

Probably in draft status, but could go in if deemed good enough.

Yours,
   Petr.

2 patches for repository darcs-unstable at darcs.net:darcs:

Tue Jan 19 19:55:33 CET 2010  Petr Rockai <me at mornfall.net>
  * Require Cabal 1.8, fix the build-deps dump in --exact-version.

Tue Jan 19 19:56:21 CET 2010  Petr Rockai <me at mornfall.net>
  * Take advantage of Cabal 1.8 internal library capability.

----------
files: require-cabal-1_8_-fix-the-build_deps-dump-in-__exact_version_.dpatch, unnamed
messages: 9866
nosy: darcs-users, mornfall
status: needs-review
title: Require Cabal 1.8, fix the build-deps du... (and 1 more)

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch147>
__________________________________
-------------- next part --------------
A non-text attachment was scrubbed...
Name: require-cabal-1_8_-fix-the-build_deps-dump-in-__exact_version_.dpatch
Type: text/x-darcs-patch
Size: 89205 bytes
Desc: not available
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100119/b4d2fd6f/attachment-0001.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: unnamed
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100119/b4d2fd6f/attachment-0001.diff>


More information about the darcs-users mailing list