[darcs-users] [patch147] Require Cabal 1.8, fix the build-deps du... (and 1 more)

Petr Ročkai bugs at darcs.net
Wed Jan 20 20:19:00 UTC 2010


Petr Ročkai <me at mornfall.net> added the comment:

Amended to avoid conflict with Ganesh's extensible-exceptions work. A timely
review would be quite useful, as this is currently blocking the 3 of our
buildslaves that use Cabal 1.8 from building darcs. (Applying this will likely
break the others, but we can fix those by installing Cabal 1.8. I would have to
pull the 6.12 buildslave in order to avoid 1.8...)

Yours,
   Petr.

2 patches for repository darcs-unstable at darcs.net:darcs:

Tue Jan 19 19:55:33 CET 2010  Petr Rockai <me at mornfall.net>
  * Require Cabal 1.8, fix the build-deps dump in --exact-version.

Wed Jan 20 20:55:15 CET 2010  Petr Rockai <me at mornfall.net>
  * Take advantage of Cabal 1.8 internal library capability.

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch147>
__________________________________
-------------- next part --------------
A non-text attachment was scrubbed...
Name: require-cabal-1_8_-fix-the-build_deps-dump-in-__exact_version_.dpatch
Type: text/x-darcs-patch
Size: 90850 bytes
Desc: not available
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100120/17a879b7/attachment-0001.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: unnamed
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100120/17a879b7/attachment-0001.diff>


More information about the darcs-users mailing list