[darcs-users] [patch147] Require Cabal 1.8, fix the build-deps du... (and 1 more)

Petr Ročkai bugs at darcs.net
Wed Jan 20 22:02:30 UTC 2010


Petr Ročkai <me at mornfall.net> added the comment:

This amendment fixes witnesses and unit tests (now they work after first patch
as well after second patch).

However, it seems that it's not such a great idea to apply the second patch
just yet, as Duncan says (and I can confirm) that cabal-install does not grok
this yet. Also, he said it is broken with GHC 6.12, which is probably even
worse.

Anyway, after this iteration, at least the 1.8 bump should work.

Yours,
   Petr.

2 patches for repository darcs-unstable at darcs.net:darcs:

Wed Jan 20 22:51:58 CET 2010  Petr Rockai <me at mornfall.net>
  * Require Cabal 1.8, fix the build-deps dump in --exact-version.

Wed Jan 20 22:53:33 CET 2010  Petr Rockai <me at mornfall.net>
  * Take advantage of Cabal 1.8 internal library capability.

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch147>
__________________________________
-------------- next part --------------
A non-text attachment was scrubbed...
Name: require-cabal-1_8_-fix-the-build_deps-dump-in-__exact_version_.dpatch
Type: text/x-darcs-patch
Size: 93242 bytes
Desc: not available
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100120/725cf180/attachment-0001.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: unnamed
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100120/725cf180/attachment-0001.diff>


More information about the darcs-users mailing list