[darcs-users] [patch147] Require Cabal 1.8, fix the build-deps du... (and 1 more)

Ganesh Sittampalam bugs at darcs.net
Wed Jan 20 22:27:39 UTC 2010


Ganesh Sittampalam <ganesh at earth.li> added the comment:

I've so far tried this on GHC 6.8.3 and 6.12.1, using cabal-install
0.8.0 built against Cabal 1.8.0.2.

6.12.1 is fine.
with 6.8.3, I had to install the Cabal 1.8.0.2 library before I could
cabal install darcs (it wasn't installed already as cabal-install was
built with a different GHC). Is there any alternative to this, like
adding Cabal 1.8 as an explicit build-dep too?

I also want to try with GHC 6.10.4 before accepting this patch, which
I'll do tomorrow night. If anyone else wants to do it in the meantime
and apply this, go ahead. Remember only to apply the first patch.

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch147>
__________________________________


More information about the darcs-users mailing list