[darcs-users] deep freeze for the 2.5 release: release blockers

Reinier Lamers tux_rocker at reinier.de
Fri Jul 23 19:17:05 UTC 2010

Hi all,

Beginning yesterday, the 2.5 branch of darcs has been deep-frozen. This means 
that only "release-critical fixes" can go in. This is the time to make it more 
concrete what a "release-critical fix" is.

Browsing the bug tracker and the mailing list, I see the following issues that 
I would not like to see in a stable darcs release:

   * The "HTTP packs stuff" mentioned by Petr in a reply to the announcement
     of the release schedule
   * The bug in bundle creation (http://bugs.darcs.net/issue1892)
   * A bug in pulling a certain repo (http://bugs.darcs.net/issue1831, easily
   * The brokenness of darcs diff --index (http://bugs.darcs.net/issue1290)

For issue1892, the second point, there is a patch waiting to be reviewed and 

For the first point, Eric said it is easy to disable it. Eric, can you submit 
a patch to do that?

For the last two points, we need volunteers to look at them and either fix 
them or report that it's not worth fixing for 2.5 for some reason.

I will release the second beta this weekend as scheduled. After that I will 
make new release candidates in as soon as a week has gone by and some of these 
release-critical issues have been resolved.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100723/186e83ca/attachment.pgp>

More information about the darcs-users mailing list