[darcs-users] GHC 6.8?

Ganesh Sittampalam ganesh at earth.li
Tue Mar 16 22:45:32 UTC 2010


Hi,

After just going through a bit of pain with having to constrain dependent 
packages to old versions for GHC 6.8.3, I found myself wondering how long 
more we're going to support GHC 6.8 for. Do we have a policy on this 
already? If not can we start discussing it?

For the record, here are the problems I had:

text-0.7.1.0 doesn't build on 6.8.3 because it depends on the Data.Data 
module which was first introduced in 6.10.

QuickCheck-2.1.0.3 doesn't build with profiling for reasons I don't quite 
understand - it complains about the "Panic" module from the ghc-6.8.3 
package not being built for profiling, but this is likely to be a bit 
painful to fix if it really is the problem.

In turn this requires constraining test-framework-quickcheck2 to < 0.2.5 
(why didn't cabal figure that out for itself?)

In addition to the above there is a type witnesses failure which is no 
doubt my fault and I plan to fix asap, unless we actually decide to drop 
6.8 right now.

Cheers,

Ganesh


More information about the darcs-users mailing list