[darcs-users] GHC 6.8?

Eric Kow kowey at darcs.net
Wed Mar 17 22:58:27 UTC 2010


On Thu, Mar 18, 2010 at 09:34:46 +1100, Trent W. Buck wrote:
> I bootstrapped 6.12 from 6.10 from 6.8 on Ubuntu Hardy to generate a
> statically-linked Darcs binary for one of the GHC guys to use on the
> platform.  At most it took me a full afternoon, and that's without any
> experience building GHC from source.

So I imagine it does not really help us all that much to require the
very latest GHC, but how about we

 (i) Synch to a more regularly updated Linux distribution as our
     heartbeat.  I suggest Ubuntu (popularity?).  So now the current
     release is Karmic, with GHC 6.10.

 (ii) Before we permit ourselves to raise the GHC requirement, we
      write reproducible instructions on http://wiki.darcs.net/Debian
      for building Darcs with only binaries provided by Debian and
      source.
      
      The instructions don't have to provide 100% hand-holding, just
      the basic information you need to build Darcs with some standard
      skills (./configure, make, make install).  It could look
      something like this

      1. apt-get install ghc
      2. get GHC 6.10 src [link to tarballs]
      3. build
      ...
      8. get darcs src [link to tarball]
      9. cabal install darcs

We don't go all the way to the bleeding edge (because it's
inconvenient), but we stay recent enough to maintain our own sanity (and
to keep things more predictable) and we do a minimum to try to take care
of our more conservative users.

Is that reasonable?

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20100317/b727f39d/attachment.pgp>


More information about the darcs-users mailing list