[darcs-users] [patch414] fix a sed regexp in hidden_conflicts2.sh

gh bugs at darcs.net
Sat Oct 9 11:36:16 UTC 2010


gh <guillaumh at gmail.com> added the comment:

Another remark: hidden_conflicts2.sh passes also with --hashed
repositories (darcs1 patch type). So maybe this test is just useless
and should be removed.
hidden_conflicts.sh does fail with --hashed repos, on the other hand.

Guillaume

2010/10/9 gh <bugs at darcs.net>:
>
> New submission from gh <guillaumh at gmail.com>:
>
> This fixes a silent bug in a tests shellscript, where a sed would not
> erase the conflict markers. I am using Ubuntu Linux 10.10 with GNU
> sed version 4.2.1. I have grepped the other tests to look for similar
> regexpes, but no other occurence of grep or sed do this kind of treatment
> on conflict markers.
>
> Note also that Ganesh's recent patch to add the previous text in conflict
> marking will make a line of ===== remain after the current version of this
> patch, so the alternative = will have to be added to the sed regexp.
> 1 patch for repository http://darcs.net:
>
> Sat Oct  9 12:16:52 CEST 2010  Guillaume Hoffmann <guillaumh at gmail.com>
>  * fix a sed regexp in hidden_conflicts2.sh
>
> ----------
> files: fix-a-sed-regexp-in-hidden_conflicts2_sh.dpatch, unnamed
> messages: 12667
> nosy: gh
> status: needs-screening
> title: fix a sed regexp in hidden_conflicts2.sh
>
> __________________________________
> Darcs bug tracker <bugs at darcs.net>
> <http://bugs.darcs.net/patch414>
> __________________________________

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch414>
__________________________________


More information about the darcs-users mailing list