[darcs-users] Apply failed

Sittampalam, Ganesh ganesh.sittampalam at credit-suisse.com
Tue Oct 19 14:04:37 UTC 2010

Benjamin Franksen wrote:
> Benjamin Franksen wrote:
>> I already reported this for beta-3 (Message-ID:
>> <i4j4pt$etj$1 at dough.gmane.org>). The same happens with beta-4:
>>> darcs push
>> Pushing to "/srv/csr/repositories/controls/darcs/epics/ioc/MLS-
>> Controls/base-3-14"... Mon Aug 23 10:51:18 CEST 2010 
>>   benjamin.franksen at bessy.de * removed repeated and obsolete lines
>> in req file (EnergyRampApp) Shall I push this patch? (1/2) 
>> [ynW...], or ? for more options: y Mon Aug 23 15:24:10 CEST 2010 
>>   benjamin.franksen at bessy.de * added kickers to energy ramp
>> (EnergyRampApp) Shall I push this patch? (2/2)  [ynW...], or ? for
>> more options: d 
>> darcs: <stdin>: hIsTerminalDevice: illegal operation (handle is
>> closed) Apply failed! 
>> This is from a fresh copy of the repo ('darcs get' from the shared
>> repo
>> then pulled in the two new patches). 
>> Strangely, I get the same error now if I use darcs-2.4.4!
> I tried with the latest beta and it happened again.
> I think this bug should be resolved in darcs-2.5.
> I think I have a fix, but I would rather like to test this with the
> 2.5 release branch, instead of the mainline repo. However, I cannot
> find this repo on the wiki.  


I've just added a note to http://wiki.darcs.net/Development/FAQ

Thanks for the testing and the hoped-for fix! Is there a bugtracker bug
for your problem?



Please access the attached hyperlink for an important electronic communications disclaimer: 

More information about the darcs-users mailing list