[darcs-users] "screened" now fails to build on Ubuntu 10.04 due to apparent requirement of GHC 7.

Mark Stosberg mark at summersault.com
Mon Oct 1 17:54:47 UTC 2012

On 02/27/2012 02:46 PM, Mark Stosberg wrote:
> On 02/18/2012 02:15 AM, Aditya wrote:
>> libncurses5-dev provides curses.h.
>> http://packages.ubuntu.com/lucid/libncurses5-dev
> Thanks. I can confirm after installing this package I was able to build
> Darcs 2.8 on Ubuntu 10.04, Lucid Lynx.

I'm interested to try out the latest changes from "screened", but it
appears that the version requirements for GHC have changed.

Ubuntu 10.04 (supported until April 2015) has only 6.12, so I get this:

  setup: The program ghc version >=7.0 && <7.6 is required but the
  version found

What's the recommendation for Ubuntu 10.04 users who would like to use
the latest darcs?


More information about the darcs-users mailing list