[darcs-users] "screened" now fails to build on Ubuntu 10.04 due to apparent requirement of GHC 7.

Ganesh Sittampalam ganesh at earth.li
Tue Oct 2 06:30:31 UTC 2012

Hi Mark,

On 01/10/2012 18:54, Mark Stosberg wrote:

> I'm interested to try out the latest changes from "screened", but it
> appears that the version requirements for GHC have changed.
> Ubuntu 10.04 (supported until April 2015) has only 6.12, so I get this:
>   setup: The program ghc version >=7.0 && <7.6 is required but the
>   version found

Yeah, this is deliberate:
http://darcs.net/Development/Policy#ghc-versions - I'm fairly sure that
we've also now made code changes that won't work on GHC 6.12.

> What's the recommendation for Ubuntu 10.04 users who would like to use
> the latest darcs?

5 years is a long time in GHC terms!

I'd suggest downloading a binary distribution of a more recent GHC from
http://www.haskell.org/ghc/download, and use that to build darcs.

To install the binary, unpack it somewhere, ./configure
--prefix=/some/where ; make install

Then point your PATH at /some/where/bin, and build darcs.



More information about the darcs-users mailing list