[darcs-users] Trying to upgrade darcs - cabal error
ash.moran at patchspace.co.uk
Sun Mar 10 13:46:39 UTC 2013
On 10 Mar 2013, at 13:27, Eric Kow <eric.kow at gmail.com> wrote:
> Maybe cabal install --verbose utf8-string
Sadly that's not much more helpful :-( (output below)
I think what I'll do later is nuke my cabal install and re-install it from Homebrew.
(Perhaps the Haskell Platform binary would be more reliable, but as I only use GHC to compile darcs, having a build system for just that one tool means I forget what it's put where. It'd probably just get out of date, and I'd forget how to upgrade it etc.)
% cabal install --verbose utf8-string
Reading available packages...
Choosing modular solver.
Flags chosen: bytestring-in-base=False
Dependency base ==184.108.40.206: using base-220.127.116.11
Dependency bytestring ==0.9.2.1: using bytestring-0.9.2.1
The build-tool has reset ENV. --env=std required.
Updating world file...
cabal: Error: some packages failed to install:
utf8-string-0.3.7 failed during the configure step. The exception was:
More information about the darcs-users