[darcs-users] darcs 2.10.1 release

Guillaume Hoffmann guillaumh at gmail.com
Thu Jul 9 17:04:10 UTC 2015

Hi all,

The darcs team is pleased to announce the release of darcs 2.10.1 !

# Downloading #

The easiest way to install darcs 2.10.1 from source is by first
installing the Haskell Platform (http://www.haskell.org/platform). If
you have installed the Haskell Platform or cabal-install, you can
install this release by doing:

$ cabal update
$ cabal install darcs-2.10.1

Alternatively, you can download the tarball from
http://darcs.net/releases/darcs-2.10.1.tar.gz and build it by hand as
explained in the README file.

The 2.10 branch is also available as a darcs repository from

# What's new in 2.10.1 (since 2.10.0) #

- generalized doFastZip for darcsden support
- support terminfo 0.4, network 2.6, zlib 0.6, quickcheck 2.8 and
attoparsec 0.13
- errorDoc now prints a stack trace (if profiling was enabled) (Ben Franksen)
- beautified error messages for command line and default files (Ben Franksen)
- fixed the following bugs:
      - issue2449: test harness/shelly: need to handle
mis-encoded/binary data (Ganesh Sittampalam)
      - issue2423: diff only respecting --diff-command when a diff.exe
is present (Alain91)
      - issue2447: get contents of deleted file (Ben Franksen)
      - issue2307: add information about 'darcs help manpage' and
'darcs help markdown' (Dan Frumin)
      - issue2461: darcs log --repo=remoterepo creates and populates
_darcs (Ben Franksen)
      - issue2459: cloning remote repo fails to use packs if cache is
on a different partition (Ben Franksen)

# Feedback #

If you have an issue with darcs 2.10.0, you can report it on
http://bugs.darcs.net/ . You can also report bugs by email to
bugs at darcs.net, or come to #darcs on irc.freenode.net.

# Known issues #

- issue2269: rebase should warn about stolen patches at suspend, not unsuspend
- issue2272: darcs rebase unsuspend should automate or semi-automate
handling unrecorded changes
- issue2276: darcs rebase unsuspend needs UI improvements for "You are
not... Amend anyway?"
- issue2359: convert --export mishandles Unicode filenames
- issue2372: Please remove "HINT: I could not reach..." message
- issue2436: rollback --patches takes ages before first prompt
- issue2445: internal error if suspended patch is pulled into repository again

More information about the darcs-users mailing list