[darcs-users] darcs 2.10.2 release

Guillaume Hoffmann guillaumh at gmail.com
Mon Nov 9 14:08:55 UTC 2015

The darcs team is pleased to announce the release of darcs 2.10.2 !

# Downloading #

The easiest way to install darcs 2.10.2 from source is by first
installing the Haskell Platform (http://www.haskell.org/platform). If
you have installed the Haskell Platform or cabal-install, you can
install this release by doing:

$ cabal update
$ cabal install darcs-2.10.2

Alternatively, you can download the tarball from
http://darcs.net/releases/darcs-2.10.2.tar.gz and build it by hand as
explained in the README file.

The 2.10 branch is also available as a darcs repository from

# What's new in 2.10.2 (since 2.10.1) #

 * optimize patch apply code memory use
 * make patch selection lazier in presence of matchers
 * switch patches retrieval order when using packs
 * switch from dataenc (deprecated) to sandi
 * finish updating help strings with new command names
 * clean contrib scripts
 * disable mmap on Windows
 * enhance darcs send message
 * fix quickcheck suite
 * shorter README with quickstart instructions
 * fixed the following bugs:

    * 2457: fix darcs-test command line options
    * 2463: building darcs on powerpc
    * 2444: added default interactivity parameter to isInteractive

# Feedback #

If you have an issue with darcs 2.10.2, you can report it on
http://bugs.darcs.net/ . You can also report bugs by email to
bugs at darcs.net, or come to #darcs on irc.freenode.net.

More information about the darcs-users mailing list