[Intel-wired-lan] [next PATCH v4 1/3] mm: Rename __alloc_page_frag to page_frag_alloc and __free_page_frag to page_frag_free

Bowers, AndrewX andrewx.bowers at intel.com
Fri Jan 13 20:57:15 UTC 2017


> -----Original Message-----
> From: Intel-wired-lan [mailto:intel-wired-lan-bounces at lists.osuosl.org] On
> Behalf Of Alexander Duyck
> Sent: Tuesday, January 03, 2017 6:40 PM
> To: intel-wired-lan at lists.osuosl.org; Kirsher, Jeffrey T
> <jeffrey.t.kirsher at intel.com>
> Cc: linux-mm at kvack.org; akpm at linux-foundation.org; linux-
> kernel at vger.kernel.org
> Subject: [Intel-wired-lan] [next PATCH v4 1/3] mm: Rename
> __alloc_page_frag to page_frag_alloc and __free_page_frag to
> page_frag_free
> 
> From: Alexander Duyck <alexander.h.duyck at intel.com>
> 
> This patch renames the page frag functions to be more consistent with other
> APIs.  Specifically we place the name page_frag first in the name and then
> have either an alloc or free call name that we append as the suffix.  This
> makes it a bit clearer in terms of naming.
> 
> In addition we drop the leading double underscores since we are technically
> no longer a backing interface and instead the front end that is called from the
> networking APIs.
> 
> Signed-off-by: Alexander Duyck <alexander.h.duyck at intel.com>
> ---
> 
> v2: Fixed a comparison between a void* and 0 due to copy/paste from
> free_pages
> v3: Dropped changes to function and make this a rename patch only.
>     This fixes a small performance regression I saw in some tests.
> v4: Added back page_frag_alloc which had leaked through to patch 2 after
>     I had tried reordering them in my own queue.
> 
>  include/linux/gfp.h    |    6 +++---
>  include/linux/skbuff.h |    2 +-
>  mm/page_alloc.c        |   10 +++++-----
>  net/core/skbuff.c      |    8 ++++----
>  4 files changed, 13 insertions(+), 13 deletions(-)

Tested-by: Andrew Bowers <andrewx.bowers at intel.com>




More information about the Intel-wired-lan mailing list