[Intel-wired-lan] [PATCH 05/18] net: use ARRAY_SIZE

Andy Shevchenko andy.shevchenko at gmail.com
Mon Oct 2 13:07:36 UTC 2017


On Sun, Oct 1, 2017 at 10:30 PM, Jérémy Lefaure
<jeremy.lefaure at lse.epita.fr> wrote:
> Using the ARRAY_SIZE macro improves the readability of the code. Also,
> it is not always useful to use a variable to store this constant
> calculated at compile time.
>

> +       {&gainctrl_lut_core0_rev0, ARRAY_SIZE(gainctrl_lut_core0_rev0), 26, 192,
> +        32},

For all such cases I would rather put on one line disregard checkpatch
warning for better readability.

-- 
With Best Regards,
Andy Shevchenko


More information about the Intel-wired-lan mailing list