[Intel-wired-lan] i40e pppoe rss

Jesse Brandeburg jesse.brandeburg at intel.com
Thu Oct 14 19:52:17 UTC 2021


On 10/12/2021 12:28 PM, Jesse Brandeburg wrote:
> On 10/11/2021 3:28 PM, Benjamin LaHaise wrote:
>> I have been trying to get RSS working for incoming PPPoE packets with the
>> Linux i40e driver.  After loading the DDP .pkgo file for PPPoE using
>> "ethtool -f enp43s0f0 ppp-oe-ol2tpv2.pkgo 100", packets still come in 
>> on a
>> single queue.  Changing destination IP addresses or port numbers in UDP
>> packets does not result in any change in the ingress queue.  Are the
>> ethtool commands required to enable RSS with PPPoE documented anywhere?
>> The only documentation seems to rely on test-pmd with DPDK, but I am 
>> using
>> the native Linux drivers and XDP.
> 
> Hi Ben, this was a known issue on an older package version, and since 
> you asked, we realized that the version on intel.com hasn't been updated 
> in a long time, and so doesn't have the fix.
> 
> We are working to correct the internal issues that lead to this stale 
> package being left there and not updated, and are grateful you pointed 
> us to the issue!
> 
> Please keep an eye out for the intel.com download page to be updated 
> with the latest PPPoE package. Once you have that, RSS should start 
> working correctly after loading the newer package.
> 
> Thanks for your patience, I don't have a direct ETA on this, but I did 
> start the ball rolling internally.

The latest package has been uploaded, feedback is appreciated.
https://downloadcenter.intel.com/download/28040

Jesse


More information about the Intel-wired-lan mailing list