[Intel-wired-lan] [PATCH v5 iwl-next] i40e: Use correct buffer size in i40e_dbg_command_read
Nelson, Shannon
shannon.nelson at amd.com
Wed Dec 20 01:32:18 UTC 2023
On 12/17/2023 9:54 PM, Pucha, HimasekharX Reddy wrote:
>
>> -----Original Message-----
>> From: Intel-wired-lan <intel-wired-lan-bounces at osuosl.org> On Behalf Of Kunwu Chan
>> Sent: Friday, December 8, 2023 8:50 AM
>> To: Brandeburg, Jesse <jesse.brandeburg at intel.com>; Nguyen, Anthony L <anthony.l.nguyen at intel.com>; davem at davemloft.net; edumazet at google.com; kuba at kernel.org; pabeni at redhat.com; jeffrey.t.kirsher at intel.com; shannon.nelson at amd.com
>> Cc: Kunwu Chan <chentao at kylinos.cn>; Kunwu Chan <kunwu.chan at hotmail.com>; netdev at vger.kernel.org; linux-kernel at vger.kernel.org; Lobakin, Aleksander <aleksander.lobakin at intel.com>; intel-wired-lan at lists.osuosl.org; Simon Horman <horms at kernel.org>
>> Subject: [Intel-wired-lan] [PATCH v5 iwl-next] i40e: Use correct buffer size in i40e_dbg_command_read
>>
>> The size of "i40e_dbg_command_buf" is 256, the size of "name"
>> depends on "IFNAMSIZ", plus a null character and format size,
>> the total size is more than 256.
>>
>> Improve readability and maintainability by replacing a hardcoded string
>> allocation and formatting by the use of the kasprintf() helper.
>>
>> Fixes: 02e9c290814c ("i40e: debugfs interface")
>> Suggested-by: Simon Horman <horms at kernel.org>
>> Suggested-by: Alexander Lobakin <aleksander.lobakin at intel.com>
>> Suggested-by: Tony Nguyen <anthony.l.nguyen at intel.com>
>> Cc: Kunwu Chan <kunwu.chan at hotmail.com>
>> Signed-off-by: Kunwu Chan <chentao at kylinos.cn>
>> ---
>> v2
>> - Update the size calculation with IFNAMSIZ and sizeof(i40e_dbg_command_buf)
>> v3
>> - Use kasprintf to improve readability and maintainability
>> v4
>> - Fix memory leak in error path
>> v5
>> - Change the order of labels
>> ---
>> .../net/ethernet/intel/i40e/i40e_debugfs.c | 20 ++++++++++---------
>> 1 file changed, 11 insertions(+), 9 deletions(-)
>>
>
> Tested-by: Pucha Himasekhar Reddy <himasekharx.reddy.pucha at intel.com> (A Contingent worker at Intel)
>
Much of this debugfs command code was an early driver hack that probably
never should have gone upstream in the form that it did. The
i40e_dbg_command_buf itself was originally meant as a scratchpad to put
the 'last command processed', which was not really very useful, and as a
static global that might be written by any number of instances of i40e
devices, was problematic from the beginning. Now, unless I'm mistaken,
it looks like nothing is writing to the buffer at all anymore, so the
buffer and the i40e_dbg_command_read() callback probably should just all
go away rather than trying to pretty up some useless code.
sln
More information about the Intel-wired-lan
mailing list