[Maintain-dev] [JIRA] Commented: (MNT-1442) Search - Searching for users doesn't work

Zack Bartel (JIRA) jira at osuosl.org
Thu Jun 22 16:02:51 PDT 2006


     [ http://bugs.osuosl.org/browse/MNT-1442?page=comments#action_11025 ]
     
Zack Bartel commented on MNT-1442:
----------------------------------

This is happening because both zone_user and user use the field 'username' and there is no distinction being made between them. Also, since db naming "conventions" are so messed up, when doing many-many searches I use the first "key" in the object to grab the value from the junction table. for instance the 'workgroup' field in zone_workgroup points to the 'id' of the workgroup table. in zone_user there is a 'username' field that points to a 'username' field in the 'user' table. This would all be so simple if we changed (corrected?) the db naming.

> Search - Searching for users doesn't work
> -----------------------------------------
>
>          Key: MNT-1442
>          URL: http://bugs.osuosl.org/browse/MNT-1442
>      Project: Maintain
>         Type: Bug
>     Versions: 3.0
>     Reporter: Michael Clay
>     Assignee: Zack Bartel
>      Fix For: 3.0

>
>
> When searching for a user the list that is returned doesn't contain anything of relevance, clicking on an entry, if you're lucky enough to get a result back, doesn't bring up the edit page, it forwards you to the user datalist where all users are visible.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://bugs.osuosl.org/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira



More information about the Maintain-dev mailing list