[Replicant] Replicant 6.0 0004 RC2 images are ready for testing.

Denis 'GNUtoo' Carikli GNUtoo at cyberdimension.org
Wed Jul 22 11:37:24 UTC 2020


Hi,

I've just pushed the 0004 RC2 images. I've not started to test them but
I'll start soon.

Like with the Replicant 6.0 0004 RC1 images, the most important thing
to know (copied from the release notes draft[1]) is that you cannot keep
the data partition between Replicant 6.0 0003 and Replicant 6.0 0004
RC2:
> It will also not be possible to keep the data partition and a full re-
> installation will be necessary. Users are advised to backup the
> important data from the applications (contacts, SMS, etc) before
> migrating to a this release. There are already [some tips][23] on how
> to backup some applications. We didn’t have enough time to investigate
> the precise cause of the issue.

Black screen issue fix and slow graphics:
-----------------------------------------
In the Replicant 6.0 0004 RC2 images, all the devices with an OMAP4
System On a Chip didn't complete the boot and were stuck on a black
screen.

The following devices were affected:
- Galaxy Nexus (GT-I9250)
- Galaxy Tab 2 (GT-P3100, GT-P3110, GT-P5100, GT-P5110)

This should now be fixed.

The new default OpenGL implementation (llvmpipe) now work on these
devices, however it is significantly slower than the old Android OpenGL
implementation (libagl), up to the point where the devices are unusable
at that speed.

The speed is fast enough to run a command that reverts to the old
OpenGL implementation. To do that you need to type one command as root.

We tried to find a way to revert only the affected devices to the old
OpenGL implementation in the source code but the tests in doing that
were too much time consuming and we didn't want to delay too much the
new RC2 images nor take too much time away from our work on Replicant
10.

To type the command as root, you first need to make sure that root
access is enabled, or to enable it. Here's a way to do that:
> To allow root access, open the "Developer options" in the settings.
> There, press "Root access". In the pop-up menu, select either "Apps
> only" or "Apps and ADB". A window with "Allow root access?" might pop
> up and explains the security tradeoffs of enabling root access. After
> reading the text, select OK to enable root access.

Now that root access is enabled we need to find a way to type the
command. As there is a terminal application in Replicant 6.0 we will
use it.

That application is not enabled by default. To enable it you need to
find the "Local terminal" setting which is a bit below the "Root
access" settings and make sure it is enabled.

Then to get root access in the terminal you can simply type the 'su'
command (without the quotes) and press enter.

A "Privacy Guard" warning might popup, asking you to allow root for
that application. As we need root, you need to allow it.

Then you can finally run the following command as root:
'graphics.sh faster' (without the quotes) and press enter.

The device will then revert back to the old OpenGL implementation
and reboot.

Fixes since Replicant 6.0 0004 RC1:
-----------------------------------
- With the modem scripts, silence wasn't finding the SIM card after the
  modem was enabled/disabled. This is now fixed.
- The modem and graphics scripts user interface were reworked to be more
  intuitive. While doing that we made sure that they worked with the
  stock keyboard on the supported smartphone that has the smallest
  screen size (The Galaxy SII).

The release notes didn't change (yet) since the RC1. They are available
in the first mail of the "Replicant 6.0 0004 RC1" thread here:
https://lists.osuosl.org/pipermail/replicant/2020-January/002452.html

Development notes:
------------------
I accidentally pushed the replicant-6.0-dev manifest to the
replicant-6.0-0004-rc2 tag without any additional commit that changed
the revisions. Because of that I had to re-tag the manifest git
repository and force-push the rewritten tag with the new commit.

So if you already checked out the source code at the
replicant-6.0-0004-rc2 tag before that release was announced you need
to re-fetch/checkout the source.

In addition I've already sent patches to the mailing list to document
and improve the release process to prevent such mistakes from happening
again (given that nothing was documented, and the ways the tools
worked, it was way too easy to make mistakes like that).

References:
-----------
[1]This part is based on the following HOWTO:
   https://redmine.replicant.us/projects/replicant/wiki/ADB

Denis.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.osuosl.org/pipermail/replicant/attachments/20200722/5845b075/attachment.asc>


More information about the Replicant mailing list