[Replicant] Replicant on 9300 samsung - sim not detected

Denis 'GNUtoo' Carikli GNUtoo at cyberdimension.org
Sat Mar 6 14:25:45 UTC 2021

On Fri, 5 Mar 2021 23:34:39 +0100
Andrés Domínguez <andresdju at gmail.com> wrote:

> Hi md.
> Replicant not detecting the SIM card it's increasingly often. It
> happened to me, my i9300 stopped detecting any SIM card. I Installed
> Lineage and it didn't fixed it.
This seems to be a very different issue from the one I described in my
previous reply to md.

> Then I flashed the modem.bin rom in the RADIO partition and it didn't
> fixed it. But installing stock (samsung) images including modem.bin
> and booting stock Samsung Android fixed it. Then I reinstalled
> Replicant and it works fine so far. Some other Replicant users have
> reported booting stock also fixing it for them.
This looks like a very light corruption of the data in the modem data
partition (EFS). 

I've started doing some investigation on that but I will probably need
more time, information and devices to continue working on that.

We now have a tutorial on the wiki about backuping the EFS partition[1],
which is now part of the installation instructions.

If the EFS gets corrupted beyond repair by Replicant and/or the stock
distribution, you will not be able to use the modem anymore as we don't
know how to recreate it from scratch (yet).

The issue is that it's device specific: it contains the device IMEI, so
having multiple devices on the network with the same IMEI is probably
not a good idea as they could potentially end up being blocked.

On older devices (Nexus S and maybe Galaxy S) we have code[2] to read
the IMEI from the EFS, but not yet to change it. Being able to change it
would enable people to repair (older) phones with completely corrupted
EFS for instance.

Currently if we encode a different IMEI in the same format it is
encoded and write it into the EFS instead of the previous one, the
modem will overwrite it with the old one, so something is missing in my

If someone has information on that or links to information on that I
could finally implement the missing part.

In the meantime we always need to do backups of this EFS partition.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.osuosl.org/pipermail/replicant/attachments/20210306/70366f9a/attachment.asc>

More information about the Replicant mailing list