[Replicant] stuck on startup

Denis 'GNUtoo' Carikli GNUtoo at cyberdimension.org
Wed Sep 1 22:02:28 UTC 2021


On Wed, 01 Sep 2021 11:31:47 +0000
Fil Lupin via Replicant <replicant at osuosl.org> wrote:

> Hello,
Hi,

> after reading the docs, especially NIST and Samsung, I realized that
> encryption follows the same standard described so it should be seen
> the same way other phone are seen. I tried again to decrypt the phone
> and it works!
> 
> I'll look at the few apps I installed before the crash to identify if
> one of them causes the crash.
> 
> Thank you again for the docs links,
Thanks a lot for all these infos on how to do it and for reporting the
fact that it works!!!

It's super important as before we didn't know if it was even possible
for users with the password to actually recover their data if they
encrypted it, we only hoped / supposed that it was possible.

For instance I personally didn't use encryption and even advocated
against it in this case precisely because of that issue as I was worried
that users (me included) could end up in situations where we would
completely loose access to our data.

Even without encryption I sometime had to recover data because I
messed up with system application signing keys, and it took me quite
some time to get familiar with the Android security model (hopefully I
wrote some wiki articles about it along the way).

So we know know it's at least possible to recover, and we know a way
that could work, as it worked for you, though it seems to still be quite
technical and not that reliable (as you had to try twice).

With Replicant >= 11 we need to switch encryption to something way more
standard that works with cryptsetup and if possible udisks2 too to avoid
all this mess.

In any case I also think that It would be super useful if someone (you
or someone else reading this mail) would create a wiki article with at
least a pointer to this thread or some information on how to recover
that data if time permits that.

Thanks again for the report about it and trying ways to recover your
data.

Denis.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.osuosl.org/pipermail/replicant/attachments/20210902/5555f7cd/attachment-0001.asc>


More information about the Replicant mailing list