[Replicant] Replicant 6 on i9300 user feedback

Simon Josefsson simon at josefsson.org
Thu Sep 8 08:40:29 UTC 2016

Hi all.

I took some time to build replicant 6 for i9300 from scratch on a fresh
Debian 8 virtual machine, following the instructions on the forum page
https://redmine.replicant.us/boards/21/topics/12057 and the wiki.  Below
are some observations.

*) In general it appears usable as a day-to-day phone with SMS/MMS,
   Phone, Web browser, fdroid, apps, etc.  I'm switching from my old
   Replicant 4 setup to this today.  Compared to regular Android/CM,
   graphics is slow, but it feels snappier than replicant 4.  ZXing does
   not work, and the small app screenshots in the task switcher does not
   work -- these are known graphical issues.  Previews in the Gallery
   now works, compared to Replicant 4.  VLC video playback does not work
   (crashes replicant, see below), and this worked in replicant 4 so
   this is the only regression I've noticed.

*) I put my build files https://josefsson.org/replicant6/ -- I did not
   get the sign-build script to do anything useful for me, so the ROM
   use test-keys and are signed with my PGP key.

*) I got front-camera, bluetooth and wifi to work using non-free
   firmware from cm-10.1.3.  NFC works fine out of the box.  I haven't
   worked on getting GPS to work.  See non-free firmware notes at

*) Upgrading fdroid fails because it is signed using a different key?  I
   put the latest fdroid on there so right now this is not a problem for

*) I've seen hard reboot crashes when doing:
   * Recording video in camera app
   * Attempting playback of video through VLC

*) I've seen soft crashes:
   * Trebuchet crashes when managing icons in a sub-folder on the

*) Wiki suggestions (anyone wants to grant me write access?)


Mention that you need to run on debian-like systems:
dpkg --add-architecture i386 && apt-get update
before installing packages -- for zlib1g-dev:i386

Drop redundant 'curl' from Debian 8 packages.

*) Ironically, the same day I did this, my nexus 5x received Android 7.
   Still, yay for replicant 6!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 472 bytes
Desc: not available
URL: <http://lists.osuosl.org/pipermail/replicant/attachments/20160908/0d27cde7/attachment.asc>

More information about the Replicant mailing list