[Replicant] Fdroid 1.0.1 with privileged extension causes crashes

Kurtis Hanna kurtis at riseup.net
Tue Nov 14 20:38:00 UTC 2017

I have experienced 'Trebushet crashed' problem with the newest version
of Orbot (I obtained the APK from their github releases page) and with
the Twidere app when I upgraded from F-Droid.

Perhaps this issue thread could shine light on the problem:

I was told on the Replicant IRC that Wolfgang has a solution to this
problem and it will be fixed in the next Replicant release. I forgot who
told me that. Is that true Wolfgang?

In Solidarity,

> Hi all,
> I agree this seems like a bigger issue in Replicant. I came across a 
> very similar issue a few days ago; I installed the latest Signal 
> (4.12.3), and after that the phone kept crashing, either never 
> getting past the replicant boot logo, or sometimes booting up but 
> then often showing 'Trebushet crashed' and generally crashing and 
> restarting itself within 5 minutes.  I solved the issue by removing 
> the app, using adb shell in one of those 5 minute windows to delete 
> the appropriate directory in /data/app. Installing the previous 
> version (4.12.2) worked fine.  This isn't from fdroid, these were 
> APKs from apkmirror.com (which makes me nervous at the best of 
> times...)
> I don't have a lot of time to look into this (hence not reporting 
> this sooner), but figured maybe this could act as another datapoint.
> Nick
> Quoth Simon Josefsson:
>> Hi all.  As far as I understand, the problem is a genuine Replicant ROM
>> bug that needs to be fixed.  The problematic DAVDroid version appears
>> to have been removed from fdroid so everything works fine now. 
>> Yesterday I upgraded the app 'Call Recorder', and experience something
>> similar to the DAVdroid boot-loop issue.  With the new Call Recorder
>> app, replicant crashed and on startup 'Trebuchet crashed' just keeps
>> looping and the background icon page just comes and goes.  Removing the
>> app resolves the issue.  Does anyone else see this?  Is this the same
>> ROM bug or something else?  It seems that whatever problem there is
>> with the DAVDroid/CallRecorder-apps, it should not be possible for an
>> app to cause these kind of problems with the phone.
>> /Simon
>> mån 2017-11-06 klockan 09:27 +0100 skrev Simon Josefsson:
>>> lör 2017-11-04 klockan 12:09 +0100 skrev maurice at prtrc.net:
>>>> Hi Simon
>>>>> I am running Replicant 6.0 0002 on an i9300 and it has been
>>>>> working
>>>>> fine.  It came with fdroid privileged extension pre-
>>>>> installed.  It
>>>>> hasn't been possible to upgrade it because it was signed with a
>>>>> different key, so I have been using the version that came with
>>>>> 6.0
>>>>> 0002.
>>>>> After upgrading fdroid to 1.0.1, replicant crashes on installing
>>>>> an
>>>>> app
>>>>> through fdroid.  Replicant doesn't come up again, and just keeps
>>>>> looping on startup (boot logo, adb works).  After a factory reset
>>>>> I
>>>>> reproduced this (stock 0002 image, upgrade fdroid, install any
>>>>> app
>>>>> ->
>>>>> crash), so it seems like a geniune bug.
>>>>> After another factory reset, I upgraded fdroid to 1.0.1 and
>>>>> disabled
>>>>> use of the privileged extension and installing apps works fine
>>>>> and
>>>>> doesn't cause replicant crashes.
>>>>> 1) Can anyone reproduce this?
>>>> I can reproduce the crashing and looping, but for me it doesn't
>>>> work
>>>> with factory reset and disabling the privileged extension to
>>>> install
>>>> apps without crashing and looping again.
>>> The privileged extension was a red herring -- the culprit is apps
>>> aapt2-built apk's.  The DAVDroid 1.9.1 app in fdroid triggers
>>> this.  On
>>> my tests above I didn't try to install DAVDroid, only some other
>>> apps.
>>> See more here:
>>> https://forums.bitfire.at/topic/1603/replicant-lineage-1-9-1-causing-
>>> in
>>> stant-crash-and-bootloops
>>> Indeed the way to recover from the bootloop is to (re)move the
>>> /data/app/*davdroid* directory.  Then your phone can boot and you can
>>> revert back to davdroid 1.9 or (presumably) wait for 1.9.2.
>>> Hopefully replicant 6 0003 can be released to fix the OS bug too?!  I
>>> believe Wolfgang found a patch to fix this.
>>> /Simon
>> _______________________________________________
>> Replicant mailing list
>> Replicant at osuosl.org
>> https://lists.osuosl.org/mailman/listinfo/replicant
> _______________________________________________
> Replicant mailing list
> Replicant at osuosl.org
> https://lists.osuosl.org/mailman/listinfo/replicant

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.osuosl.org/pipermail/replicant/attachments/20171114/798d08c4/attachment.asc>

More information about the Replicant mailing list