[Replicant] Calendar and address book syncing without google. Not working.

A. F. Cano afc at shibaya.lonestar.org
Sat Nov 18 02:59:00 UTC 2017

While not strictly a Replicant issue (I installed Cyanogenmod way back
then as Replicant wasn't installable on this phone) I try to stay as
close to the spirit of Replicant as possible.  Thus, nothing Google on
this phone.  I got the apps (other than the default ones) from F-droid.org.

I did post a detailed report to the DAVdroid forum that can be found here:


but got absolutely no response.

I hope the people here might have some insights.  The relevant apps are
"Calendar" and "People" as they came with Cyanogenmod, and "Tasks" as
obtained from F-droid.org.  The latter is the only one that works.  The
to-do list shows up properly and is synchronized from the Radicale server.

The Calendar and Contacts/Address book show nothing.  It seems to me that
this is a DAVdroid issue, but the deafening silence from that forum is
really discouraging.  Calendar storage and Contacts storage both exist and
are running.  The Radicale server works fine with KOrganizer/Kaddressbook
so I doubt it's a server issue.

The server: Radicale 1.1.1+20160118-4 as it comes with the freedombox (testing

The android side: Samsung galaxy S (SGH-T959 aka Vibrant) running Cyanogenmod
10.1-20140217 vibrantmtd, Android 4.2.2, kernel 3.0.86 Feb 16, 2014.  I think
this is the latest version available for this phone.  Calendar build
4.2.2-5f0d87f6af.  Contacts build 4.2.2-5f0d87f6af.

Detailed description of the problem is in the DAVdroid forum post above.
I did notice there a post indicating crashes under Replicant, so I downgraded
to DAVdroid 1.9.  The crashes went away but I still get:

[syncadapter.SyncManager] Couldn't access local storage

Does anyone know what might be causing this?  Any workaround or solution?
Any other apps available other than DAVdroid to do calDAV and cardDAV? I
couldn't find anything that seemed relevant on f-droid.
CalDAV sync adapter is present and running.

Finally, has anyone tried to run the current Replicant (6) on this phone?
Upgrading to Replicant 6 would be a major deal and given that it took me
weeks to get CM working and configured I would only attempt this if I have
some confidence that it will work.



More information about the Replicant mailing list