Hi everyone!<div><br></div><div>I've just started with ROS.</div><div><br></div><div>I installed ROS on Ubuntu 10.4 following the tutorial on the website. I installed boxturtle_base, after which I installed the tutorials.</div>
<div><br></div><div>When I started doing the tutorials I ran into some problems. At the 3rd tutorial, when I try to install turtle_teleop I get the following:</div><div><br></div><div><div>$ rosdep install turtle_teleop</div>
<div>Failed to find stack for package [joy]</div><div>Failed to load rosdep.yaml for package [joy]:Cannot locate installation of package joy: [rospack] couldn't find package [joy]. ROS_ROOT[/home/blazz/ros/ros] ROS_PACKAGE_PATH[/home/blazz/ros-tutorials/ros_pkg_tutorials:/home/blazz/ros-tutorials/ros_tutorials:]</div>
<div>Failed to find stack for package [spacenav_node]</div><div>Failed to load rosdep.yaml for package [spacenav_node]:Cannot locate installation of package spacenav_node: [rospack] couldn't find package [spacenav_node]. ROS_ROOT[/home/blazz/ros/ros] ROS_PACKAGE_PATH[/home/blazz/ros-tutorials/ros_pkg_tutorials:/home/blazz/ros-tutorials/ros_tutorials:]</div>
<div>Failed to find stack for package [ps3joy]</div><div>Failed to load rosdep.yaml for package [ps3joy]:Cannot locate installation of package ps3joy: [rospack] couldn't find package [ps3joy]. ROS_ROOT[/home/blazz/ros/ros] ROS_PACKAGE_PATH[/home/blazz/ros-tutorials/ros_pkg_tutorials:/home/blazz/ros-tutorials/ros_tutorials:]</div>
<div>Failed to find stack for package [wiimote]</div><div>Failed to load rosdep.yaml for package [wiimote]:Cannot locate installation of package wiimote: [rospack] couldn't find package [wiimote]. ROS_ROOT[/home/blazz/ros/ros] ROS_PACKAGE_PATH[/home/blazz/ros-tutorials/ros_pkg_tutorials:/home/blazz/ros-tutorials/ros_tutorials:]</div>
<div>[rosstack] couldn't find dependency [joystick_drivers] of [ros_pkg_tutorials]</div><div>[rosstack] missing dependency</div><div>executing this script:</div><div>áset -o errexit</div><div>#No Packages to install</div>
</div><div><br></div><div>So it seems I'm missing the drivers on the joystick_drivers stack. I look for it and it seems to be missing:</div><div><br></div><div><div>$ rosstack find joystick_drivers</div><div>[rosstack] couldn't find stack joystick_drivers</div>
</div><div><br></div><div>However when I go to the ros folder I have it under stacks:</div><div><br></div><div><div>blazz@blazz-ros:~/ros$ ls</div><div>ros ásetup.sh ástacks áthis.rosinstall</div><div>blazz@blazz-ros:~/ros$ cd stacks/</div>
<div>camera_drivers/ á á á driver_common/ á á á áimu_drivers/ á á á á ánavigation/ á á á á á simulator_stage/ á á ávisualization/ á á á á</div><div>common/ á á á á á á á geometry/ á á á á á á joystick_drivers/ á á physics_ode/ á á á á áslam_gmapping/ á á á ávisualization_common/á</div>
<div>common_msgs/ á á á á áimage_common/ á á á á laser_drivers/ á á á árobot_model/ á á á á ásound_drivers/ á á á á</div><div>diagnostics/ á á á á áimage_pipeline/ á á á laser_pipeline/ á á á simulator_gazebo/ á á vision_opencv/ á á á á</div>
<div><br></div></div><div>What am I missing here?</div><div><br></div><div>Thanks for the help.</div><div><br></div><div>Gonšalo Cabrita</div><div>ISR - University of Coimbra</div><div>Portugal</div><div><br></div>