I received the same errors today: <meta http-equiv="content-type" content="text/html; charset=utf-8"><a href="http://pastebin.com/b70kSndj">http://pastebin.com/b70kSndj</a><div><br></div><div>This is due to the recent change that points /usr/bin/python to python-3.x. The only workaround I could think of was to remove the symlink and point it instead to /usr/bin/python2.7, after which ROS successfully installed and compiled.</div>

<div><br></div><div>Does anyone know if there is an "official" fix?</div><div><br></div><div>Soo-Hyun Yoo<br><br><div class="gmail_quote">On Fri, Oct 22, 2010 at 5:00 PM, Morgan Quigley <span dir="ltr"><<a href="mailto:mquigley@cs.stanford.edu">mquigley@cs.stanford.edu</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">I haven't used Arch in a while now, since I finally converted to<br>
Ubuntu last year. I'm not sure if there is anybody else using ROS<br>
actively on Arch, but if so they will hopefully chime in.<br>
<br>
To get that error, did you download the rosinstall script and just run<br>
it, or did you try to build rospack manually?<br>
<font color="#888888"><br>
-Morgan<br>
</font><div><div></div><div class="h5"><br>
<br>
On Fri, Oct 22, 2010 at 2:49 AM, Tadele Shiferaw <<a href="mailto:metitad@gmail.com">metitad@gmail.com</a>> wrote:<br>
>  I am trying to install ROS on archlinux and I get the following error when trying to use rosinstall...<br>
><br>
> print "Rospack failed to build"<br>
>                                  ^<br>
> SyntaxError: invalid syntax<br>
> Traceback (most recent call last):<br>
>  File "/usr/bin/rosinstall", line 5, in <module><br>
>    pkg_resources.run_script('rosinstall==0.5.8', 'rosinstall')<br>
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 489, in run_script<br>
>    self.require(requires)[0].run_script(script_name, ns)<br>
>  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 1214, in run_script<br>
>    exec script_code in namespace, namespace<br>
>  File "/usr/lib/python2.7/site-packages/rosinstall-0.5.8-py2.7.egg/EGG-INFO/scripts/rosinstall", line 501, in <module><br>
><br>
>  File "/usr/lib/python2.7/site-packages/rosinstall-0.5.8-py2.7.egg/EGG-INFO/scripts/rosinstall", line 492, in rosinstall_main<br>
><br>
>  File "/usr/lib/python2.7/subprocess.py", line 504, in check_call<br>
>    raise CalledProcessError(retcode, cmd)<br>
> subprocess.CalledProcessError: Command 'source /home/user1/ros/setup.sh && rosmake rostest --rosdep-install' returned non-zero exit status 1<br>
><br>
><br>
> Any help is appreciated<br>
> _______________________________________________<br>
> ros-users mailing list<br>
> <a href="mailto:ros-users@code.ros.org">ros-users@code.ros.org</a><br>
> <a href="https://code.ros.org/mailman/listinfo/ros-users" target="_blank">https://code.ros.org/mailman/listinfo/ros-users</a><br>
><br>
_______________________________________________<br>
ros-users mailing list<br>
<a href="mailto:ros-users@code.ros.org">ros-users@code.ros.org</a><br>
<a href="https://code.ros.org/mailman/listinfo/ros-users" target="_blank">https://code.ros.org/mailman/listinfo/ros-users</a><br>
</div></div></blockquote></div><br></div>